Comment changer la version PHP à 7 pour votre site Joomla ? | 007 hébergement

Comment changer la version PHP à 7 pour votre site Joomla ?

Procédure

Pourquoi changer la version PHP à 7 sur Joomla ?

Comment changer la version PHP à 7 pour votre site Joomla ?

Depuis quelques temps, vous pouvez trouver en vous connectant à l'administration de votre site Joomla, la phrase suivante:

" Votre version PHP ne recoit en ce moment que des correctifs de sécurité du projet PHP. Cela signifie que votre version PHP ne sera bientôt plus prise en charge. Nous vous recommandons de planifier la mise à niveau vers une nouvelle version de PHP."

Il est donc préférable de changer la version PHP utilisée par mesure de sécurité. Cependant, il faut obligatoirement suivre quelques règles afin d'éviter d'avoir une erreur 500 sur son site Web.

Comment mettre à jour la version PHP à la version 7 pour Joomla ?

Lorsque vous allez changer de version PHP, de la version 5.6 à 7.1, 7.2, 7.3, 7.4 voir 8.0 (New), cela peut avoir une incidence sur le fonctionnement de votre site Joomla. Il est vrai que cette mise à jour est nécessaire au bon fonctionnement de votre site et permet d'éviter des problèmes en matière de sécurité. Cependant, une méthodologie est à suivre afin de ne pas avoir de dysfocntionnement sur votre site Web.

Afin d'éviter tout problème, il est conseillé de:

  • Lister les composants installés sur votre site Web
  • Vérifier si tous vos composants sont bien à jour
  • Vérifier la compatibilité de vos composants avec la version PHP 7 que vous allez mettre en place

Si l'un des composants a été installé il y a quelques temps déjà et que vous avez un doute sur sa compatibilité avec la version PHP7.1 ou supérieur, il est préférable de désinstaller ce composant. Il vous faudra aussi désinstaller tous les composants qui ne sont pas compatibles avec la nouvelle version de Joomla.

1. Une fois tous les composants vérifiés, connectez-vous à votre espace client et cliquez sur "Domaine et hébergement"

Comment changer la version PHP à 7 pour votre site Joomla ?

2. Cliquez sur "Admin/Administrer" se trouvant derrière le nom de domaine pour lequel vous désirez modifier la version PHP

Comment changer la version PHP à 7 pour votre site Joomla ?

3. Cliquez sur le bouton "Configuration PHP" se trouvant dans la rubrique "5 - Gestion MySQL/PHP/Sauvegardes"

Comment changer la version PHP à 7 pour votre site Joomla ?

4. Modifiez la version PHP pour la version 7.1 ou supérieur. Cliquez enfin sur le bouton "Valider" afin de sauvegarder votre demande. La version PHP sera mis à jour dans l'heure suivant votre demande.

Comment changer la version PHP à 7 pour votre site Joomla ?

Conclusion

Vous êtes désormais en mesure de changer la version PHP sur votre site Joomla avec votre hébergement Web LWS. Cependant, il est à noté qu'il est nécessaire de vérifier avant toute chose, la compatibilité de vos composant avec la version 7.0 ou supérieur de PHP.

N'hésitez pas à partager vos remarques et vos questions!

Notez cet article :

Cet article vous a été utile ?

Article utileOui

Article non utileNon

Vous souhaitez nous laisser un commentaire concernant cet article ?

Si cela concerne une erreur dans la documentation ou un manque d'informations, n'hésitez pas à nous en faire part depuis le formulaire.

Pour toute question non liée à cette documentation ou problème technique sur l'un de vos services, contactez le support commercial ou le support technique

Merci ! N'hésitez pas à poser des questions sur nos documentations si vous souhaitez plus d'informations et nous aider à les améliorer.


Vous avez noté 0 étoile(s)

Articles similaires

1mn de lecture

Comment configurer PHP sur mon hébergement ?

2mn de lecture

Comment créer une tâche cron ?

3mn de lecture

Personnalisation des pages d'erreur

0mn de lecture

Comment accéder aux Logs Apache / Php


Questions sur l'article
Thierry Il y a 572 jours
Bonjour Comment vérifier la compatibilité de mes composants avec une nouvelle version PHP que je souhaite mettre à jour car LWS me conseille de passer de la version PHP 5.3.29 à la version 5.6 Merci d'avance
Voir les
1 réponses
fabrice-LWS - Il y a 565 jours
Bonjour, effectivement, il est nécessaire de changer de version PHP pour la version 5.6 dans la mesure ou la version PHP 5.3 sera définitivement abandonnée à compter du mois de février. Si votre site utilise Wordpress, Joomla ou Prestashop, le changement de version PHP ne devrait pas poser problème. Vous pouvez dans tous les cas, tester un changement de version PHP en vous rendant sur votre espace client, cliquez sur "Gérer" se trouvant derrière votre domaine puis sur "Configuration PHP". Si la version PHP pose problème, il vous faaudra changer de formule pour une formule cPanel sur laquelle la version PHP 5.3 continuera d'être présente. Il vous sera possible de changer de version PHP en vous rendant sur l'administration de votre formule puis sur "Changer de formule". Avant d'effectuer le changement de formule, il vous sera nécessaire d'effectuer une sauvegarde de vos données.
Utile ?

Poser une question à l'équipe LWS et à sa communauté